summaryrefslogtreecommitdiff
path: root/zephyr/shim/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/shim/src/CMakeLists.txt')
-rw-r--r--zephyr/shim/src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/shim/src/CMakeLists.txt b/zephyr/shim/src/CMakeLists.txt
index e5101e8dbd..be283829cc 100644
--- a/zephyr/shim/src/CMakeLists.txt
+++ b/zephyr/shim/src/CMakeLists.txt
@@ -7,6 +7,8 @@ zephyr_sources(gpio.c)
zephyr_sources(util.c)
zephyr_sources(crc.c)
+zephyr_sources_ifdef(no_libgcc libgcc_${ARCH}.S)
+
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_ESPI espi.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_FLASH flash.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_HOOKS hooks.c)