summaryrefslogtreecommitdiff
path: root/zephyr/test/crc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/crc/CMakeLists.txt')
-rw-r--r--zephyr/test/crc/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/zephyr/test/crc/CMakeLists.txt b/zephyr/test/crc/CMakeLists.txt
new file mode 100644
index 0000000000..d8b4d9fadc
--- /dev/null
+++ b/zephyr/test/crc/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright 2020 The Chromium OS Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+# SPDX-License-Identifier: Apache-2.0
+
+cmake_minimum_required(VERSION 3.13.1)
+set(BOARD native_posix)
+project(tasks)
+find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
+
+# We need to include the EC include directory and this local test directory
+# for the task defines
+zephyr_include_directories("${PLATFORM_EC}/include")
+
+# Include the test source and the file under test
+target_sources(app PRIVATE main.c)
+target_sources(app PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/../../shim/src/crc.c")