summaryrefslogtreecommitdiff
path: root/zephyr/test/hooks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/hooks/CMakeLists.txt')
-rw-r--r--zephyr/test/hooks/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/test/hooks/CMakeLists.txt b/zephyr/test/hooks/CMakeLists.txt
index e44ebfe674..2236963762 100644
--- a/zephyr/test/hooks/CMakeLists.txt
+++ b/zephyr/test/hooks/CMakeLists.txt
@@ -23,5 +23,7 @@ zephyr_include_directories(
# Include test file, test under test and console dependency
target_sources(app PRIVATE hooks.c)
+target_sources(app PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/../../../common/printf.c")
target_sources(app PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/../../shim/src/hooks.c")
target_sources(app PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/../../shim/src/console.c")
+target_sources(app PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/../../shim/src/util.c")