summaryrefslogtreecommitdiff
path: root/zephyr/test/nissa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/nissa/CMakeLists.txt')
-rw-r--r--zephyr/test/nissa/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/zephyr/test/nissa/CMakeLists.txt b/zephyr/test/nissa/CMakeLists.txt
index dc351aa3b6..6574575a09 100644
--- a/zephyr/test/nissa/CMakeLists.txt
+++ b/zephyr/test/nissa/CMakeLists.txt
@@ -10,8 +10,17 @@ add_subdirectory(${PLATFORM_EC}/zephyr/test/test_utils test_utils)
zephyr_include_directories("${PLATFORM_EC_PROGRAM_DIR}/nissa/include")
-target_sources(app PRIVATE src/stubs.c src/sub_board.c)
+target_sources(app PRIVATE src/stubs.c)
-target_sources(app PRIVATE
- ${PLATFORM_EC_PROGRAM_DIR}/nissa/src/sub_board.c
+target_sources_ifdef(
+ CONFIG_TEST_NISSA_SUB_BOARD
+ app PRIVATE
+ src/sub_board.c
+ src/log_module.c
+ ${PLATFORM_EC_PROGRAM_DIR}/nissa/src/sub_board.c)
+
+target_sources_ifdef(
+ CONFIG_TEST_NISSA_COMMON
+ app PRIVATE
+ src/common.c
${PLATFORM_EC_PROGRAM_DIR}/nissa/src/common.c)