summaryrefslogtreecommitdiff
path: root/zephyr/test/skyrim/tests/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/skyrim/tests/common/CMakeLists.txt')
-rw-r--r--zephyr/test/skyrim/tests/common/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/zephyr/test/skyrim/tests/common/CMakeLists.txt b/zephyr/test/skyrim/tests/common/CMakeLists.txt
index 251f7e6ad5..a7e59e686a 100644
--- a/zephyr/test/skyrim/tests/common/CMakeLists.txt
+++ b/zephyr/test/skyrim/tests/common/CMakeLists.txt
@@ -2,4 +2,12 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
-target_sources(app PRIVATE src/common.c) \ No newline at end of file
+target_sources(app PRIVATE src/common.c)
+
+# PPC config
+if (DEFINED CONFIG_TEST_BOARD_PPC_CONFIG)
+ target_sources(app PRIVATE ${PLATFORM_EC_PROGRAM_DIR}/skyrim/${CONFIG_TEST_BOARD_NAME}/src/ppc_config.c)
+ if (NOT DEFINED CONFIG_TEST_BOARD_PPC_CONFIG_CUSTOM)
+ target_sources(app PRIVATE src/ppc_config.c)
+ endif()
+endif() \ No newline at end of file