summaryrefslogtreecommitdiff
path: root/zephyr/zmake/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/zmake/setup.py')
-rw-r--r--zephyr/zmake/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/zephyr/zmake/setup.py b/zephyr/zmake/setup.py
index 4328dc48d7..51001c6695 100644
--- a/zephyr/zmake/setup.py
+++ b/zephyr/zmake/setup.py
@@ -24,8 +24,8 @@ setuptools.setup(
# requirements files see:
# https://packaging.python.org/en/latest/requirements.html
install_requires=[
- "jsonschema>=3.2.0",
- "pyyaml>=3.13",
+ # Required until chroot upgrades to Python 3.7+.
+ "dataclasses>=0.6; python_version < '3.7'",
],
# To provide executable scripts, use entry points in preference to the
# "scripts" keyword. Entry points provide cross-platform support and allow