summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoan Touzet <wohali@users.noreply.github.com>2017-09-20 04:28:46 -0400
committerGitHub <noreply@github.com>2017-09-20 04:28:46 -0400
commite474da0643e30c5a540957900d36a8b1303009d3 (patch)
tree6866f27d6915bc5cc2d3947492bfcf434e447c1b
parentdae81befd57940d0777402b21c05a2e3c58014d7 (diff)
downloadcouchdb-e474da0643e30c5a540957900d36a8b1303009d3.tar.gz
Run mango tests with make check (#786)
* Run mango tests with make check * Update README-DEV.rst
-rw-r--r--.travis.yml2
-rw-r--r--Makefile1
-rw-r--r--README-DEV.rst33
3 files changed, 24 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 56a2b7d71..8aebaabc6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -58,7 +58,7 @@ before_script:
- cd ../..
script:
- - make check mango-test
+ - make check
after_failure:
- build-aux/logfile-uploader.py
diff --git a/Makefile b/Makefile
index c1dd3a9cf..239a2db1c 100644
--- a/Makefile
+++ b/Makefile
@@ -91,6 +91,7 @@ fauxton: share/www
check: all
@$(MAKE) eunit
@$(MAKE) javascript
+ @$(MAKE) mango-test
# @$(MAKE) build-test
diff --git a/README-DEV.rst b/README-DEV.rst
index 73c684cd2..0f12fa44c 100644
--- a/README-DEV.rst
+++ b/README-DEV.rst
@@ -12,20 +12,29 @@ If you're unsure what this means, ignore this document.
Dependencies
------------
-You may need:
+You need the following to run tests:
+
+* `Python <https://www.python.org/>`_
+* `nose <https://nose.readthedocs.io/en/latest/>`_
+* `requests <http://docs.python-requests.org/>`_
+* `hypothesis <https://pypi.python.org/pypi/hypothesis>`_
+
+You need the following optionally to build documentation:
* `Sphinx <http://sphinx.pocoo.org/>`_
* `GNU help2man <http://www.gnu.org/software/help2man/>`_
* `GnuPG <http://www.gnupg.org/>`_
+
+You need the following optionally to build releases:
+
* `md5sum <http://www.microbrew.org/tools/md5sha1sum/>`_
* `sha1sum <http://www.microbrew.org/tools/md5sha1sum/>`_
+
+You need the following optionally to build Fauxton:
+
* `nodejs <http://nodejs.org/>`_
* `npm <https://www.npmjs.com/>`_
-The first four of these optional dependencies are required for building the
-documentation. The next three are needed to build releases. The last two are for
-needed to build fauxton.
-
You will need these optional dependencies installed if:
* You are working on the documentation, or
@@ -50,14 +59,16 @@ Debian-based (inc. Ubuntu) Systems
::
- sudo apt-get install help2man python-sphinx gnupg nodejs npm
+ sudo apt-get install help2man python-sphinx gnupg nodejs npm \
+ python-hypothesis python-requests python-nose
Gentoo-based Systems
~~~~~~~~~~~~~~~~~~~~
::
- sudo emerge gnupg coreutils pkgconfig help2man sphinx
+ sudo emerge gnupg coreutils pkgconfig help2man sphinx python
+ sudo pip install hypothesis requests nose
RedHat-based (Fedora, Centos, RHEL) Systems
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
@@ -65,7 +76,8 @@ RedHat-based (Fedora, Centos, RHEL) Systems
::
sudo yum install help2man python-sphinx python-docutils \
- python-pygments gnupg nodejs npm
+ python-pygments gnupg nodejs npm python-nose python-requests \
+ python-hypothesis
Mac OS X
~~~~~~~~
@@ -85,9 +97,7 @@ If you don't already have pip installed, install it::
Now, install the required Python packages::
- sudo pip install sphinx
- sudo pip install docutils
- sudo pip install pygments
+ sudo pip install sphinx docutils pygments nose requests hypothesis
FreeBSD
~~~~~~~
@@ -95,6 +105,7 @@ FreeBSD
::
pkg install help2man gnupg py27-sphinx node
+ pip install nose requests hypothesis
Windows
~~~~~~~