summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRandall Leeds <randall@apache.org>2011-06-08 08:44:13 +0000
committerRandall Leeds <randall@apache.org>2011-06-08 08:44:13 +0000
commit6ceefeb6d142b995d9a0fe578aac88105d2a0917 (patch)
treed049eaad8afc0712995d602fd36330a74491549a /configure.ac
parent3456b4e9e59688349e726c5c4c8646916d28ce03 (diff)
downloadcouchdb-6ceefeb6d142b995d9a0fe578aac88105d2a0917.tar.gz
let icu decide how to link itself
icu-config on my Ubuntu 11.04 system gives back -ansi. I changed the comments to conform and icu driver compiles. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@1133287 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 7 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index c5cd6ecb0..969e2e110 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,8 +167,6 @@ case "$(uname -s)" in
*)
# XP_UNIX required for jsapi.h and has been tested to work on Linux and Darwin.
JS_CLAGS="-DXP_UNIX $JS_CFLAGS"
- # manually linking libm is requred for FreeBSD 7.0
- LDFLAGS="-lm $LDFLAGS"
;;
esac
@@ -261,21 +259,17 @@ AC_LANG_POP(C)
AC_ARG_WITH([win32-icu-binaries], [AC_HELP_STRING([--with-win32-icu-binaries=PATH],
[set PATH to the Win32 native ICU binaries directory])], [
- ICU_CONFIG="" # supposed to be a command to query options...
- ICU_LOCAL_CFLAGS="-I$withval/include"
- ICU_LOCAL_LDFLAGS="-L$withval/lib"
- ICU_LOCAL_BIN=$withval/bin
+ ICU_CFLAGS="-I$withval/include"
+ ICU_LIBS="-L$withval/lib -licuuc -licudt -licuin"
+ ICU_BIN=$withval/bin
], [
AC_CHECK_ICU([3.4.1])
- ICU_LOCAL_CFLAGS=`$ICU_CONFIG --cppflags-searchpath`
- ICU_LOCAL_LDFLAGS=`$ICU_CONFIG --ldflags-searchpath`
- ICU_LOCAL_BIN=
+ ICU_BIN=
])
-AC_SUBST(ICU_CONFIG)
-AC_SUBST(ICU_LOCAL_CFLAGS)
-AC_SUBST(ICU_LOCAL_LDFLAGS)
-AC_SUBST(ICU_LOCAL_BIN)
+AC_SUBST(ICU_CFLAGS)
+AC_SUBST(ICU_LIBS)
+AC_SUBST(ICU_BIN)
use_curl=yes
AC_ARG_WITH([win32-curl], [AC_HELP_STRING([--with-win32-curl=PATH],