summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2012-12-06 00:05:46 +0100
committerJan Lehnardt <jan@apache.org>2012-12-06 00:05:46 +0100
commitc20240cb455c7ecb67924582b433943b435cb106 (patch)
treef4c70429f489b2a998474db7de74f11676097e01 /configure.ac
parent8e888858fb6c6de626961685f6c7b253c60e2edb (diff)
downloadcouchdb-c20240cb455c7ecb67924582b433943b435cb106.tar.gz
Require Erlang R13B04 or later
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7ce4842ca..3c0e231e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -374,7 +374,7 @@ case "$(uname -s)" in
esac
-erlang_version_error="The installed Erlang version is less than 5.6.5 (R12B05)."
+erlang_version_error="The installed Erlang version is less than 5.7.4 (R13B04)."
version="`${ERL} -version 2>&1 | ${SED} 's/[[^0-9]]/ /g'`"
@@ -382,12 +382,12 @@ if test `echo $version | ${AWK} "{print \\$1}"` -lt 5; then
AC_MSG_ERROR([$erlang_version_error])
fi
-if test `echo $version | ${AWK} "{print \\$2}"` -lt 6; then
+if test `echo $version | ${AWK} "{print \\$2}"` -lt 7; then
AC_MSG_ERROR([$erlang_version_error])
fi
-if test `echo $version | ${AWK} "{print \\$2}"` -eq 6; then
- if test `echo $version | ${AWK} "{print \\$3}"` -lt 5; then
+if test `echo $version | ${AWK} "{print \\$2}"` -eq 7; then
+ if test `echo $version | ${AWK} "{print \\$3}"` -lt 4; then
AC_MSG_ERROR([$erlang_version_error])
fi
fi