summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordoko <doko@python.org>2013-01-26 12:09:31 +0100
committerdoko <doko@python.org>2013-01-26 12:09:31 +0100
commit7e0e550bc920b8cebc7a4a73c10c174441b7354f (patch)
tree96642dc3a55e98fc5f61f66ee435d4d610a65482 /configure.ac
parent3e13e57400a1ad2733f526e3336a409efd6258f9 (diff)
parentf8121c9b9960cf01e5eb36db91945f6839d74e35 (diff)
downloadcpython-7e0e550bc920b8cebc7a4a73c10c174441b7354f.tar.gz
- Follow-up for issue #15484: In PYTHON_FOR_BUILD, use $(PLATDIR) instead
of plat-$(MACHDEP).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 15bd43ce81..a0b5066ee3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ dnl * Please run autoreconf to test your changes! *
dnl ***********************************************
# Set VERSION so we only need to edit in one place (i.e., here)
-m4_define(PYTHON_VERSION, 3.3)
+m4_define(PYTHON_VERSION, 3.4)
AC_PREREQ(2.65)
@@ -917,6 +917,7 @@ fi
# Other platforms follow
if test $enable_shared = "yes"; then
+ PY_ENABLE_SHARED=1
AC_DEFINE(Py_ENABLE_SHARED, 1, [Defined if Python is built as a shared library.])
case $ac_sys_system in
CYGWIN*)
@@ -972,6 +973,7 @@ if test $enable_shared = "yes"; then
esac
else # shared is disabled
+ PY_ENABLE_SHARED=0
case $ac_sys_system in
CYGWIN*)
BLDLIBRARY='$(LIBRARY)'
@@ -3929,6 +3931,11 @@ AC_MSG_CHECKING(LDVERSION)
LDVERSION='$(VERSION)$(ABIFLAGS)'
AC_MSG_RESULT($LDVERSION)
+dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
+AC_SUBST(PY_ENABLE_SHARED)
+LIBPL="${prefix}/lib/python${VERSION}/config-${LDVERSION}"
+AC_SUBST(LIBPL)
+
# SO is the extension of shared libraries `(including the dot!)
# -- usually .so, .sl on HP-UX, .dll on Cygwin
AC_MSG_CHECKING(SO)
@@ -4641,7 +4648,7 @@ if test "$have_gcc_asm_for_x87" = yes; then
fi
# generate output files
-AC_CONFIG_FILES(Makefile.pre Modules/Setup.config Misc/python.pc)
+AC_CONFIG_FILES(Makefile.pre Modules/Setup.config Misc/python.pc Misc/python-config.sh)
AC_CONFIG_FILES([Modules/ld_so_aix], [chmod +x Modules/ld_so_aix])
AC_OUTPUT