summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2016-09-24 12:34:31 +0200
committerChristian Heimes <christian@python.org>2016-09-24 12:34:31 +0200
commitcf95d7b7ded97ce5bc5febb57681af0f492bcd48 (patch)
tree8aaf304f296ca2ef2d36ed553bfdbbc35e5c4042 /configure.ac
parent9ffc4e6cf1964369e0d9b3729659dd947abbb683 (diff)
parent3ed4377fab2ddb08e7a9cf922bd4ddbc5d7c8094 (diff)
downloadcpython-cf95d7b7ded97ce5bc5febb57681af0f492bcd48.tar.gz
Write configure message to AS_MESSAGE_FD
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 22 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 8ce2ae998e..d3956325b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ dnl * Please run autoreconf to test your changes! *
dnl ***********************************************
# Set VERSION so we only need to edit in one place (i.e., here)
-m4_define(PYTHON_VERSION, 3.6)
+m4_define(PYTHON_VERSION, 3.7)
AC_PREREQ(2.65)
@@ -2795,23 +2795,27 @@ AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),,,)
-case "$with_system_ffi" in
- "")
- case $ac_sys_system in
- Darwin)
- with_system_ffi="no"
- ;;
- *)
- with_system_ffi="yes"
- ;;
- esac
- ;;
- yes|no)
- ;;
- *)
- AC_MSG_ERROR([--with-system-ffi accepts no arguments])
- ;;
-esac
+if test "$ac_sys_system" = "Darwin"
+then
+ case "$with_system_ffi" in
+ "")
+ with_system_ffi="no"
+ ;;
+ yes|no)
+ ;;
+ *)
+ AC_MSG_ERROR([--with-system-ffi accepts no arguments])
+ ;;
+ esac
+ AC_MSG_RESULT($with_system_ffi)
+else
+ AC_MSG_RESULT(yes)
+ if test "$with_system_ffi" != ""
+ then
+ AC_MSG_WARN([--with(out)-system-ffi is ignored on this platform])
+ fi
+ with_system_ffi="yes"
+fi
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
@@ -2820,8 +2824,6 @@ else
fi
AC_SUBST(LIBFFI_INCLUDEDIR)
-AC_MSG_RESULT($with_system_ffi)
-
# Check for use of the system libmpdec library
AC_MSG_CHECKING(for --with-system-libmpdec)
AC_ARG_WITH(system_libmpdec,