summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2004-09-18 09:54:52 +0000
committerMartin v. Löwis <martin@v.loewis.de>2004-09-18 09:54:52 +0000
commitdb87e76601652d0dfd514875b5f22ea4b616e39e (patch)
treedbb3c88560e9aae96bea49020cd7ced1851f8c18 /configure.in
parentbdae9efd97442988ca696567ced0c9af70604c2a (diff)
downloadcpython-db87e76601652d0dfd514875b5f22ea4b616e39e.tar.gz
Patch #1012280: Include curses.h for term.h check. Fixes #933795.
Will backport to 2.3.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 59a7c26789..5c9fa3d548 100644
--- a/configure.in
+++ b/configure.in
@@ -955,18 +955,21 @@ dnl AC_MSG_RESULT($cpp_type)
# checks for header files
AC_HEADER_STDC
-AC_CHECK_HEADERS(dlfcn.h fcntl.h grp.h langinfo.h \
+AC_CHECK_HEADERS(curses.h dlfcn.h fcntl.h grp.h langinfo.h \
libintl.h ncurses.h poll.h pthread.h \
stropts.h termios.h thread.h \
unistd.h utime.h \
sys/audioio.h sys/bsdtty.h sys/file.h sys/lock.h sys/mkdev.h sys/modem.h \
sys/param.h sys/poll.h sys/select.h sys/socket.h sys/time.h sys/times.h \
-sys/un.h sys/utsname.h sys/wait.h pty.h term.h libutil.h \
+sys/un.h sys/utsname.h sys/wait.h pty.h libutil.h \
sys/resource.h netpacket/packet.h sysexits.h bluetooth.h \
bluetooth/bluetooth.h)
AC_HEADER_DIRENT
AC_HEADER_MAJOR
+# On Solaris, term.h requires curses.h
+AC_CHECK_HEADERS(term.h,,,[#include <curses.h>])
+
# checks for typedefs
was_it_defined=no
AC_MSG_CHECKING(for clock_t in time.h)