summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-02-06 23:37:23 +0000
committerAndrew M. Kuchling <amk@amk.ca>2001-02-06 23:37:23 +0000
commit5af56f8cd289c755c0fbc6670b6cd886f6b358f4 (patch)
treed6c574d68003c35ec1b31987c74bf0e6fef55a28 /setup.py
parentc2a9db26e1b7cd61a968044cd8c0a25e610e8da6 (diff)
downloadcpython-5af56f8cd289c755c0fbc6670b6cd886f6b358f4.tar.gz
BeOS doesn't have a libm.a, either; noted by Donn Cave
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 572e0e46db..3c122e5e8b 100644
--- a/setup.py
+++ b/setup.py
@@ -118,6 +118,8 @@ class PyBuildExt(build_ext):
platform = sys.platform
if platform[:6] =='cygwin':
platform = 'cygwin'
+ elif platform[:4] =='beos':
+ platform = 'beos'
return platform
@@ -139,7 +141,7 @@ class PyBuildExt(build_ext):
# Check for MacOS X, which doesn't need libm.a at all
math_libs = ['m']
- if platform == 'Darwin1.2':
+ if platform in ['Darwin1.2', 'beos']:
math_libs = []
# XXX Omitted modules: gl, pure, dl, SGI-specific modules