summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2007-12-04 23:02:19 +0000
committerChristian Heimes <christian@cheimes.de>2007-12-04 23:02:19 +0000
commitfc1592ede8b053328244334279fd0f8a47cf6f80 (patch)
treecf19b1ef3e9e660a84bde8e18a817a931483da42 /setup.py
parent456d62bc7a6734ca7dfb4b275c744739327bfe20 (diff)
downloadcpython-fc1592ede8b053328244334279fd0f8a47cf6f80.tar.gz
Removed PyInt_GetMax and sys.maxint
I replaced sys.maxint with sys.maxsize in Lib/*.py. Does anybody see a problem with the change on Win 64bit platforms? Win 64's long is just 32bit but the sys.maxsize is now 2**63-1 on every 64bit platform. Also added docs for sys.maxsize.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ff2e31be2f..450bf5d17c 100644
--- a/setup.py
+++ b/setup.py
@@ -1074,7 +1074,7 @@ class PyBuildExt(build_ext):
['cjkcodecs/_codecs_%s.c' % loc]))
# Dynamic loading module
- if sys.maxint == 0x7fffffff:
+ if sys.maxsize == 0x7fffffff:
# This requires sizeof(int) == sizeof(long) == sizeof(char*)
dl_inc = find_file('dlfcn.h', [], inc_dirs)
if (dl_inc is not None) and (platform not in ['atheos']):