summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2021-02-23 12:04:29 +0000
committerViktor Szakats <commit@vsz.me>2021-02-23 12:04:29 +0000
commit95014b0a4d41723e05e8d6e3d9b0636fdd92eab6 (patch)
tree7f0e7939b817f9902eb43749e471139dc3113372 /CMakeLists.txt
parentc79b9de45ca97418e1e0daff96175254000ee5d9 (diff)
downloadcurl-95014b0a4d41723e05e8d6e3d9b0636fdd92eab6.tar.gz
build: delete unused feature guards
- `HAVE_STRNCASECMP` - `HAVE_TCGETATTR` - `HAVE_TCSETATTR` Reviewed-by: Jay Satiro Reviewed-by: Daniel Stenberg Closes #6645
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b92c2b61..62b2235cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1005,8 +1005,6 @@ check_symbol_exists(gettimeofday "${CURL_INCLUDES}" HAVE_GETTIMEOFDAY)
check_symbol_exists(inet_addr "${CURL_INCLUDES}" HAVE_INET_ADDR)
check_symbol_exists(inet_ntoa "${CURL_INCLUDES}" HAVE_INET_NTOA)
check_symbol_exists(inet_ntoa_r "${CURL_INCLUDES}" HAVE_INET_NTOA_R)
-check_symbol_exists(tcsetattr "${CURL_INCLUDES}" HAVE_TCSETATTR)
-check_symbol_exists(tcgetattr "${CURL_INCLUDES}" HAVE_TCGETATTR)
check_symbol_exists(perror "${CURL_INCLUDES}" HAVE_PERROR)
check_symbol_exists(closesocket "${CURL_INCLUDES}" HAVE_CLOSESOCKET)
check_symbol_exists(setvbuf "${CURL_INCLUDES}" HAVE_SETVBUF)