summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2003-06-27 14:37:38 +0000
committerDaniel Stenberg <daniel@haxx.se>2003-06-27 14:37:38 +0000
commit3ed3ae5bcfaf1dcc09677b2ae1e012ec227a6372 (patch)
treeb8885015fd63a2ffed51ad2d9cb848e7d92bf7e6 /Makefile.am
parent6519cc70c5c8dc04e268e4dfd9aa41463b4bc12e (diff)
downloadcurl-3ed3ae5bcfaf1dcc09677b2ae1e012ec227a6372.tar.gz
When I introduced the DIST_SUBDIRS usage, I broken the 'make install' for
include files and docs, so now I've added a custom install hook to run make install for docs and install when data is installed at the top-level.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f6c16f9a9..9b6ff5284 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,3 +78,8 @@ pkgadd:
# resulting .tar.bz2 file will end up at packages/Win32/cygwin
cygwinbin:
$(MAKE) -C packages/Win32/cygwin cygwinbin
+
+# We extend the standard install with a custom hook:
+install-data-hook:
+ cd include && $(MAKE) install
+ cd docs && $(MAKE) install