summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-17 16:03:49 +0000
committerYang Tse <yangsita@gmail.com>2008-09-17 16:03:49 +0000
commitd84440d53b70923f6d201f6a17c26814e45f160e (patch)
tree4c32c81ddf4eb4e004015cbf854abad2e2efc08b /configure.ac
parent0c1ae21c110454413f0a19ef8134e024f4c5c6ef (diff)
downloadcurl-d84440d53b70923f6d201f6a17c26814e45f160e.tar.gz
improve detection of gethostbyaddr_r() and gethostbyname_r()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d4462e32d..228b686e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1842,10 +1842,10 @@ then
else
if test "$ipv6" != "yes"; then
dnl dig around for gethostbyname_r()
- CURL_CHECK_GETHOSTBYNAME_R()
+ dnl the old gethostbyname_r check was done here
dnl dig around for gethostbyaddr_r()
- dnl CURL_CHECK_GETHOSTBYADDR_R()
+ dnl the old gethostbyaddr_r check was here BUT COMMENTED OUT
fi
dnl poke around for inet_ntoa_r()
@@ -2037,6 +2037,8 @@ CURL_CHECK_MSG_NOSIGNAL
CURL_CHECK_FUNC_FDOPEN
CURL_CHECK_FUNC_FTRUNCATE
+CURL_CHECK_FUNC_GETHOSTBYADDR_R
+CURL_CHECK_FUNC_GETHOSTBYNAME_R
CURL_CHECK_FUNC_GETHOSTNAME
CURL_CHECK_FUNC_GETSERVBYPORT_R
CURL_CHECK_FUNC_GMTIME_R