summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2007-04-30 21:47:58 +0000
committerDaniel Stenberg <daniel@haxx.se>2007-04-30 21:47:58 +0000
commit60588b2455a8eeeef9056f2819f7ecc0f11b82e2 (patch)
tree8c02cab69386fe38427ec0d4281e004a5abd71e5 /configure.ac
parent5187faeeb97321343cd0a1f3ad9aa10992513e99 (diff)
downloadcurl-60588b2455a8eeeef9056f2819f7ecc0f11b82e2.tar.gz
brlcad on #curl provided this patch (edited by me) since "configure will fail
looking for a C++ preprocessor on libtool-using projects" with the factory- installed libtool version on Mac OS X.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c38e29e1..778cfdf0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,12 +118,16 @@ AC_LIBTOOL_WIN32_DLL
dnl skip libtool C++ and Fortran compiler checks
m4_ifdef([AC_PROG_CXX], [m4_undefine([AC_PROG_CXX])])
m4_defun([AC_PROG_CXX],[])
+m4_ifdef([AC_PROG_CXXCPP], [m4_undefine([AC_PROG_CXXCPP])])
+m4_defun([AC_PROG_CXXCPP],[true])
m4_ifdef([AC_PROG_F77], [m4_undefine([AC_PROG_F77])])
m4_defun([AC_PROG_F77],[])
dnl skip libtool C++ and Fortran linker checks
m4_ifdef([AC_LIBTOOL_CXX], [m4_undefine([AC_LIBTOOL_CXX])])
m4_defun([AC_LIBTOOL_CXX],[])
+m4_ifdef([AC_LIBTOOL_CXXCPP], [m4_undefine([AC_LIBTOOL_CXXCPP])])
+m4_defun([AC_LIBTOOL_CXXCPP],[true])
m4_ifdef([AC_LIBTOOL_F77], [m4_undefine([AC_LIBTOOL_F77])])
m4_defun([AC_LIBTOOL_F77],[])