summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Silverstone <daniel.silverstone@codethink.co.uk>2013-11-19 17:06:33 +0000
committerDaniel Silverstone <daniel.silverstone@codethink.co.uk>2013-11-19 17:06:33 +0000
commit54116d3c486ed7aa49f284e4cad9e6e7c293bea6 (patch)
treefa32a75ebba262def85af97cc34a7db69bc69034 /setup.py
parent7087e92d40310d9bb6c8b4a6bb1baf7c3b73bee7 (diff)
parent4da2f9c7eaa95ebf357eeca3a497b6a206675ef8 (diff)
downloadcxmanage-54116d3c486ed7aa49f284e4cad9e6e7c293bea6.tar.gz
Merge tag 'v0.10.2' into baserock/morphbaserock/morph
v0.10 post-release tag for pyinstaller support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 22 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index bd49b13..22e5533 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,7 @@
-# Copyright (c) 2012, Calxeda Inc.
+"""Calxeda: setup.py"""
+
+
+# Copyright (c) 2012-2013, Calxeda Inc.
#
# All rights reserved.
#
@@ -31,19 +34,33 @@
from setuptools import setup
+def get_version():
+ """ Parse __init__.py to find the package version """
+ for line in open("cxmanage_api/__init__.py"):
+ key, delim, value = line.partition("=")
+ if key.strip() == "__version__" and delim == "=":
+ return value.strip().strip("'\"")
+ raise Exception("Failed to parse cxmanage package version from __init__.py")
+
setup(
name='cxmanage',
- version='0.8.2',
- packages=['cxmanage', 'cxmanage.commands', 'cxmanage_api'],
- scripts=['scripts/cxmanage', 'scripts/sol_tabs'],
+ version=get_version(),
+ packages=[
+ 'cxmanage_api',
+ 'cxmanage_api.cli',
+ 'cxmanage_api.cli.commands',
+ 'cxmanage_test'
+ ],
+ scripts=['scripts/cxmanage', 'scripts/sol_tabs', 'scripts/cxmux'],
description='Calxeda Management Utility',
# NOTE: As of right now, the pyipmi version requirement needs to be updated
# at the top of scripts/cxmanage as well.
install_requires=[
'tftpy',
'pexpect',
- 'pyipmi>=0.7.1',
+ 'pyipmi>=0.9.1',
'argparse',
+ 'unittest-xml-reporting<1.6.0'
],
extras_require={
'docs': ['sphinx', 'cloud_sptheme'],