summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4e2f47d..daba960 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,6 @@
+"""Calxeda: setup.py"""
+
+
# Copyright (c) 2012, Calxeda Inc.
#
# All rights reserved.
@@ -34,7 +37,12 @@ from setuptools import setup
setup(
name='cxmanage',
version='0.9.0',
- packages=['cxmanage', 'cxmanage.commands', 'cxmanage_api'],
+ packages=[
+ 'cxmanage_api',
+ 'cxmanage_api.cli',
+ 'cxmanage_api.cli.commands',
+ 'cxmanage_test'
+ ],
scripts=['scripts/cxmanage', 'scripts/sol_tabs'],
description='Calxeda Management Utility',
# NOTE: As of right now, the pyipmi version requirement needs to be updated
@@ -44,6 +52,7 @@ setup(
'pexpect',
'pyipmi>=0.8.0',
'argparse',
+ 'unittest-xml-reporting<1.6.0'
],
extras_require={
'docs': ['sphinx', 'cloud_sptheme'],