summaryrefslogtreecommitdiff
path: root/test/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/core/Makefile.am')
-rw-r--r--test/core/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/core/Makefile.am b/test/core/Makefile.am
index 869ca11..d1be953 100644
--- a/test/core/Makefile.am
+++ b/test/core/Makefile.am
@@ -72,6 +72,7 @@ noinst_PROGRAMS = \
test-error-mapping \
test-service-glib \
$(THREAD_APPS) \
+ manual/test-invalid-usage \
peer-server \
peer-client \
test-types \
@@ -86,6 +87,14 @@ noinst_PROGRAMS = \
test-shared-bus \
$(NULL)
+# This "test" exercises invalid usage. It is deliberately not run in
+# TESTS, because it's (by design) full of bugs.
+manual_test_invalid_usage_SOURCES = \
+ manual/invalid-usage.c \
+ my-object.c \
+ my-object.h \
+ $(NULL)
+
test_30574_SOURCES = \
30574.c