summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <quinticent@phuket.(none)>2006-07-12 21:28:39 -0400
committerJohn (J5) Palmieri <quinticent@phuket.(none)>2006-07-12 21:28:39 -0400
commit7a0389c01ac8c775b7b677bcc20cc0da716b1c19 (patch)
treecb5e85392161814e6f7e630facca0448dae13eb2 /setup.py
parent303a9d690767dd40e75940f9e3c4e1d1fa504554 (diff)
downloaddbus-python-7a0389c01ac8c775b7b677bcc20cc0da716b1c19.tar.gz
* Add tests back
* create a check command for distutils (python setup.py check)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 16 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 5b18002..65b2845 100644
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,9 @@ from Pyrex.Distutils import build_ext
import extract
+sys.path.append("test")
+from dbus_python_check import dbus_python_check
+
def remove(filename):
if os.path.exists(filename):
os.remove(filename)
@@ -74,19 +77,19 @@ setup(
author_email='johnp@redhat.com',
maintainer='John (J5) Palmieri',
maintainer_email='johnp@redhat.com',
- package_dir={'':'dbus'},
+ package_dir={'dbus':'dbus'},
py_modules=[
- "_dbus",
- "exceptions",
- "glib",
- "__init__",
- "matchrules",
- "service",
- "types",
- "decorators",
- "introspect_parser",
- "proxies",
- "_util",
+ "dbus/_dbus",
+ "dbus/exceptions",
+ "dbus/glib",
+ "dbus/__init__",
+ "dbus/matchrules",
+ "dbus/service",
+ "dbus/types",
+ "dbus/decorators",
+ "dbus/introspect_parser",
+ "dbus/proxies",
+ "dbus/_util",
],
ext_modules=[
Extension("dbus_bindings", ["dbus/dbus_bindings.pyx"],
@@ -102,7 +105,7 @@ setup(
],
),
],
- cmdclass={'build_ext': build_ext, 'clean': full_clean}
+ cmdclass={'build_ext': build_ext, 'clean': full_clean, 'check': dbus_python_check}
)
# vim:ts=4:sw=4:tw=80:si:ai:showmatch:et