summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build66
1 files changed, 66 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..8344ee2
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,66 @@
+# Copyright 2022 Collabora Ltd.
+# SPDX-License-Identifier: MIT
+
+testlib = static_library(
+ 'testutils',
+ 'util.c',
+ dependencies: [
+ dbus_dep,
+ glib_dep,
+ ],
+)
+
+test_thread_server = executable(
+ 'test-thread-server',
+ 'test-thread-server.c',
+ dependencies: [
+ dbus_gmain_dep,
+ dbus_dep,
+ glib_dep,
+ gthread_dep,
+ ],
+ link_with: testlib,
+)
+
+test_thread_client = executable(
+ 'test-thread-client',
+ 'test-thread-client.c',
+ dependencies: [
+ dbus_gmain_dep,
+ dbus_dep,
+ glib_dep,
+ gthread_dep,
+ ],
+ link_with: testlib,
+)
+
+test_cases = ['30574']
+
+foreach test_case : test_cases
+ exe = executable(
+ 'test-' + test_case,
+ test_case + '.c',
+ dependencies: [
+ dbus_gmain_dep,
+ dbus_dep,
+ glib_dep,
+ ],
+ link_with: testlib,
+ )
+ test(
+ test_case,
+ dbus_run_session,
+ args: [
+ '--',
+ exe,
+ ],
+ )
+endforeach
+
+test(
+ 'use-as-subproject',
+ find_program('python3'),
+ args: [
+ files('use-as-subproject.py'),
+ ],
+)