summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d72d8f7c..0c5cdfea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -430,6 +430,7 @@ sys/syscall.h
sys/syslimits.h
sys/time.h
unistd.h
+winsock2.h
ws2tcpip.h
])
@@ -1052,6 +1053,13 @@ if test x$dbus_win = xyes ; then
fi
fi
+AC_CHECK_HEADERS([afunix.h], [], [],
+ [AC_INCLUDES_DEFAULT[
+ #ifdef HAVE_WINSOCK2_H
+ # include <winsock2.h>
+ #endif
+ ]])
+
AC_SUBST([NETWORK_libs])
AC_ARG_WITH([valgrind],