summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5ffc4e00..5c4d2d0e 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -93,6 +93,9 @@ uninstallable_test_programs += \
$(NULL)
if DBUS_UNIX
+test_counter_SOURCES = internals/counter.c
+test_counter_LDADD = libdbus-testutils.la
+
if ENABLE_TRADITIONAL_ACTIVATION
uninstallable_test_programs += test-bus-launch-helper-oom
uninstallable_test_programs += test-bus-system
@@ -355,6 +358,14 @@ installable_manual_tests += \
$(NULL)
endif DBUS_WITH_GLIB
+if DBUS_UNIX
+if DBUS_ENABLE_EMBEDDED_TESTS
+installable_tests += \
+ test-counter \
+ $(NULL)
+endif DBUS_ENABLE_EMBEDDED_TESTS
+endif DBUS_UNIX
+
installable_test_meta = \
$(dist_installable_test_scripts:=.test) \
$(dist_installed_test_scripts:=.test) \