summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2012-07-10 12:33:46 -0400
committerRyan Lortie <desrt@desrt.ca>2012-07-10 12:33:46 -0400
commiteea502023950db2cccdb1d4fa563b05316b64419 (patch)
tree639bd6a4038adf99bbffc54d7f27bceff6316668 /Makefile.am
parent8317a107de299e5e03dc5511fefdcf5383a82bd7 (diff)
downloaddconf-eea502023950db2cccdb1d4fa563b05316b64419.tar.gz
Add script to trim bogus lcov data
There is no (apparent) way to trim branch or line coverage data from lcov output based on expression matching against the source file. This means that we get coverage results that tell us (for example) that we failed to test lines like 'g_assert_not_reached ();' or didn't test all branches of a g_assert(). Add a script to read the lcov output and remove line or branch coverage data according to a list of symbols that are known to have incomplete coverage when operating as expected.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 270b8e1..cf81afb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,7 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
# use recursive makes in order to ignore errors during check
lcov: lcov-clean
-$(MAKE) $(AM_MAKEFLAGS) -k check
- lcov --directory $(top_builddir) --capture --output-file dconf-lcov.info --test-name dconf --no-checksum --compat-libtool
+ lcov --directory $(top_builddir) --capture --test-name dconf | $(top_srcdir)/trim-lcov.py > dconf-lcov.info
LANG=C genhtml --prefix $(top_builddir) --output-directory lcov-html --legend --show-details dconf-lcov.info
@echo
@echo " file://$(abs_top_builddir)/lcov-html/index.html"