summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2010-07-18 19:37:48 -0400
committerRyan Lortie <desrt@desrt.ca>2010-07-18 19:37:48 -0400
commit46bed217bae3ffb796d9acde4c830ee3bc587852 (patch)
tree9b808e51e78d599a522b931a576bc1d56fcaa296 /bin/Makefile.am
parent1a472b2d9e36ae96bc1a034f38ac7172269d6b17 (diff)
downloaddconf-46bed217bae3ffb796d9acde4c830ee3bc587852.tar.gz
add 'dconf-update' utility
This utility scans /etc/dconf/db/ looking for directories named *.d. For each directory name.d that it finds, it reads each file contained within as a keyfile containing a list of keys to populate a dconf database with. That database is then written to 'name' (ie: the directory name with the '.d' removed), the old file is invalidated, and a signal is sent over the system DBus to indicate the change. This tool facilitates updating of dconf databases by sysadmins who prefer to follow the 'drop a text file here' approach to system management.
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index d771ce4..5544f82 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -1,6 +1,10 @@
AM_CFLAGS = -std=c89 -Wall -Wmissing-prototypes -Wwrite-strings
-INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/engine -I$(top_srcdir)/client $(gio_CFLAGS)
+INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/engine -I$(top_srcdir)/client -I$(top_srcdir)/gvdb $(gio_CFLAGS)
-bin_PROGRAMS = dconf
+bin_PROGRAMS = dconf dconf-update
dconf_LDADD = ../client/libdconf.la $(gio_LIBS)
+
+dconf_update_VALAFLAGS = --pkg=posix --pkg=gio-2.0
+dconf_update_LDADD = $(gio_LIBS)
+dconf_update_SOURCES = dconf-update.vala ../gvdb/gvdb-builder.c gvdb.vapi fixes.vapi