summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2010-07-19 12:17:48 -0400
committerRyan Lortie <desrt@desrt.ca>2010-07-19 12:17:48 -0400
commit78084a0dbfd705f214f79f8e254a54f8cb1a391f (patch)
tree0cc254fab1adeb385d7cb61062afe00ee2d79e76 /bin/Makefile.am
parent0444465d738b2632cc23614501202dac7e68abfd (diff)
downloaddconf-78084a0dbfd705f214f79f8e254a54f8cb1a391f.tar.gz
port client library to Vala
- the API is now completely implemented - update 'engine' API to be vala-bindable without annotations - update GSettings backend to new engine API - drop the readtype non-sense - build/api fixups for editor and commandline tool
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index ee64db7..8559f7c 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -3,6 +3,6 @@ INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/engine -I$(top_srcdir)/client
bin_PROGRAMS = dconf
-dconf_VALAFLAGS = --pkg=gio-2.0 ../client/dconf.vapi --pkg=posix --pkg=gio-2.0
+dconf_VALAFLAGS = --vapidir ../client --pkg=gio-2.0 --pkg=posix --pkg=dconf
dconf_LDADD = $(gio_LIBS) ../client/libdconf.la
dconf_SOURCES = dconf.vala dconf-update.vala ../gvdb/gvdb-builder.c gvdb.vapi fixes.vapi