summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2010-05-23 23:38:14 -0400
committerRyan Lortie <desrt@desrt.ca>2010-05-23 23:38:14 -0400
commita3132216e7b2fd15e675fa352dfa33c03be60f7e (patch)
tree05d26abe67f0eb61ae2a6702eb5cb8e68cef82b1 /client/Makefile.am
parentc75c4f2801c523ef48fe613bfb7b094f7a4ac7dd (diff)
downloaddconf-a3132216e7b2fd15e675fa352dfa33c03be60f7e.tar.gz
proper CFLAGS, distcheck fixes
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 1e976e8..7f98c85 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -1,5 +1,15 @@
+AM_CFLAGS = -std=c89 -Wall -Wmissing-prototypes -Wwrite-strings
+INCLUDES = -I$(top_srcdir)/{common,gvdb,engine} $(gio_CFLAGS)
+
lib_LTLIBRARIES = libdconf.la
-AM_CFLAGS = -I$(top_srcdir)/common -I$(top_srcdir)/engine $(gio_CFLAGS) -I$(top_srcdir)/gvdb
-libdconf_la_SOURCES = dconf-client.c ../common/dconf-paths.c ../engine/dconf-engine.c ../gvdb/gvdb-reader.c
+dconfinclude_HEADERS = \
+ dconf-client.h \
+ dconf.h
+
libdconf_la_LIBADD = $(gio_LIBS)
+libdconf_la_SOURCES = \
+ ../common/dconf-paths.c \
+ ../engine/dconf-engine.c \
+ ../gvdb/gvdb-reader.c \
+ dconf-client.c