summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2010-07-17 12:20:33 -0400
committerRyan Lortie <desrt@desrt.ca>2010-07-17 12:21:26 -0400
commitbece1f7488e07c2d3f2c9b978ef0065a3ab1413f (patch)
tree5f12dd60af9475f0ba909a335e84d0dc28b64fd8 /client/Makefile.am
parent6eec812ad4a014b679e630aca5fc1917a1d2b665 (diff)
downloaddconf-bece1f7488e07c2d3f2c9b978ef0065a3ab1413f.tar.gz
Move shmdir guessing code to common/
Increase the intelligence of the algorithm: use ~/.cache/dconf as a reasonable default if not on NFS. The dconf engine now has a non-blocking startup when not on NFS.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 8e17e7b..9dc20b6 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -26,6 +26,7 @@ dconfinclude_HEADERS = \
libdconf_la_LIBADD = $(gio_LIBS)
libdconf_la_SOURCES = \
+ ../common/dconf-shmdir.c \
../common/dconf-paths.c \
../engine/dconf-engine.c \
../gvdb/gvdb-reader.c \