summaryrefslogtreecommitdiff
path: root/client/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2018-08-21 15:41:51 +0000
committerPhilip Withnall <philip@tecnocode.co.uk>2018-08-21 15:41:51 +0000
commita060755f30e5c89882b160e7f284eee003a960ec (patch)
tree1765b9bdae5258808f30b421b3c95b9b15e69eef /client/meson.build
parente960b50696b95f4b035787e9cbceaa549c172c91 (diff)
parent8d76d4881f14af8a78029a89b43ce99cc558a65f (diff)
downloaddconf-a060755f30e5c89882b160e7f284eee003a960ec.tar.gz
Merge branch '1454-gvdb-corruption' into 'master'
service: Allow opening corrupt GVDB files when writing See merge request GNOME/dconf!8
Diffstat (limited to 'client/meson.build')
-rw-r--r--client/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/client/meson.build b/client/meson.build
index ce425d2..74fb090 100644
--- a/client/meson.build
+++ b/client/meson.build
@@ -12,8 +12,6 @@ install_headers(
sources = files('dconf-client.c')
-cflags = '-DG_LOG_DOMAIN="dconf"'
-
deps = [
libdconf_common_hidden_dep,
libdconf_gdbus_thread_dep,
@@ -24,7 +22,7 @@ libdconf_client = static_library(
sources: sources,
include_directories: top_inc,
dependencies: libdconf_gdbus_thread_dep,
- c_args: cflags,
+ c_args: dconf_c_args,
pic: true,
)
@@ -40,7 +38,7 @@ libdconf = shared_library(
soversion: soversion,
include_directories: top_inc,
dependencies: deps,
- c_args: cflags,
+ c_args: dconf_c_args,
install: true,
)