summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
authorDaniel Playfair Cal <daniel.playfair.cal@gmail.com>2020-12-19 01:24:57 +0000
committerDaniel Playfair Cal <daniel.playfair.cal@gmail.com>2020-12-19 01:24:57 +0000
commit6f7f010b69326eac4e8ee6e0ea7275aaf3232c80 (patch)
treee66209279f4356b1dc11b268471583c3eb17225b /common/meson.build
parent490421c6a89f918dbb75ae14efb66a1ce1fe1399 (diff)
parent72fbd6f7442a7e3dbc227068e58d082bbbefa2dc (diff)
downloaddconf-6f7f010b69326eac4e8ee6e0ea7275aaf3232c80.tar.gz
Merge branch 'fix-symbols' into 'master'
build: Improve libdconf visible symbols See merge request GNOME/dconf!59
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build16
1 files changed, 1 insertions, 15 deletions
diff --git a/common/meson.build b/common/meson.build
index 58e0fa8..befa9bc 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -28,19 +28,5 @@ libdconf_common = static_library(
libdconf_common_dep = declare_dependency(
dependencies: glib_dep,
- link_whole: libdconf_common,
-)
-
-libdconf_common_hidden = static_library(
- 'dconf-common-hidden',
- sources: sources,
- include_directories: top_inc,
- dependencies: glib_dep,
- c_args: dconf_c_args + cc.get_supported_arguments('-fvisibility=hidden'),
- pic: true,
-)
-
-libdconf_common_hidden_dep = declare_dependency(
- dependencies: glib_dep,
- link_with: libdconf_common_hidden,
+ link_with: libdconf_common,
)