summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2018-08-21 15:41:51 +0000
committerPhilip Withnall <philip@tecnocode.co.uk>2018-08-21 15:41:51 +0000
commita060755f30e5c89882b160e7f284eee003a960ec (patch)
tree1765b9bdae5258808f30b421b3c95b9b15e69eef /common/meson.build
parente960b50696b95f4b035787e9cbceaa549c172c91 (diff)
parent8d76d4881f14af8a78029a89b43ce99cc558a65f (diff)
downloaddconf-a060755f30e5c89882b160e7f284eee003a960ec.tar.gz
Merge branch '1454-gvdb-corruption' into 'master'
service: Allow opening corrupt GVDB files when writing See merge request GNOME/dconf!8
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/common/meson.build b/common/meson.build
index 90245b7..58e0fa8 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -17,14 +17,12 @@ sources = files(
'dconf-paths.c',
)
-cflags = ['-DG_LOG_DOMAIN="dconf"']
-
libdconf_common = static_library(
'dconf-common',
sources: sources,
include_directories: top_inc,
dependencies: glib_dep,
- c_args: cflags,
+ c_args: dconf_c_args,
pic: true,
)
@@ -33,14 +31,12 @@ libdconf_common_dep = declare_dependency(
link_whole: libdconf_common,
)
-cflags += cc.get_supported_arguments('-fvisibility=hidden')
-
libdconf_common_hidden = static_library(
'dconf-common-hidden',
sources: sources,
include_directories: top_inc,
dependencies: glib_dep,
- c_args: cflags,
+ c_args: dconf_c_args + cc.get_supported_arguments('-fvisibility=hidden'),
pic: true,
)