summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-08-07 10:58:23 -0400
committerRyan Lortie <desrt@desrt.ca>2012-10-22 23:55:29 +0200
commit390126b07492faa53c36b42bff4cd0d92b5f5e52 (patch)
tree1c20e6dc02c1e9b7aa72856f2f4ae3525380951b /configure.ac
parentf732fba794d380a6c70ce7f82c3326a484909fba (diff)
downloaddconf-390126b07492faa53c36b42bff4cd0d92b5f5e52.tar.gz
build: Add --disable-man
1) For embedded systems, it makes no sense to include documentation of this kind on each image. So we might as well not even build it. 2) For people bootstrapping systems from source code, documentation is the source of many cyclical build loops. Allowing it to be disabled helps cut these loops. 3) The Docbook stylesheets are distributed as Zip files, and the gnome-ostree builder only consumes git repositories. https://bugzilla.gnome.org/show_bug.cgi?id=681385
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c411c27..1932485 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,18 @@ fi
AC_PROG_CC
AM_PROG_VALAC([0.17.0])
AC_PROG_RANLIB
-AC_PATH_PROG([XSLTPROC], [xsltproc])
+AC_ARG_ENABLE(man,
+ [AS_HELP_STRING([--enable-man],
+ [generate man pages [default=yes]])],,
+ enable_man=yes)
+
+AS_IF([test "$enable_man" != no], [
+ AC_PATH_PROG([XSLTPROC], [xsltproc])
+ AS_IF([test -z "$XSLTPROC"], [
+ AC_MSG_ERROR([xsltproc is required for --enable-man])
+ ])
+])
+AM_CONDITIONAL(ENABLE_MAN, test "$enable_man" != no)
# Use GSettings
GLIB_GSETTINGS