summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2012-08-06 13:20:44 -0400
committerRyan Lortie <desrt@desrt.ca>2012-08-06 16:53:20 -0400
commitc8672ee78d7258af57e36664419877c6799ab69c (patch)
treeeaefc6783501595c5d49190cf6bef8cf55c680a0 /configure.ac
parentff98e96217fdad5429ecb73c90efc80f8f7a5466 (diff)
downloaddconf-c8672ee78d7258af57e36664419877c6799ab69c.tar.gz
Enable i18n support for dconf-editor
Add i18n support using intltool and glib-gettext (to avoid the well-known issues with vanilla gettext). This patch is heavily based on a patch by Gabor Kelemen. https://bugzilla.gnome.org/show_bug.cgi?id=642217
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c1e9fa3..f82571c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,14 @@ if test "x$enable_gcov" == "xyes"; then
LDFLAGS="$LDFLAGS -lgcov"
fi
+dnl Gettext support
+GETTEXT_PACKAGE=dconf
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, ["$GETTEXT_PACKAGE"], [Define the gettext package to be used])
+
+AM_GLIB_GNU_GETTEXT
+IT_PROG_INTLTOOL([0.50.0])
+
AC_CONFIG_FILES([
common/Makefile
shm/Makefile
@@ -79,9 +87,10 @@ AC_CONFIG_FILES([
dbus-1/Makefile
bin/Makefile
editor/Makefile
- editor/dconf-editor.desktop
+ editor/dconf-editor.desktop.in
tests/Makefile
docs/Makefile
+ po/Makefile.in
Makefile
])
AC_OUTPUT