summaryrefslogtreecommitdiff
path: root/gvdb/meson.build
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw@src.gnome.org>2018-10-21 12:31:47 +0800
committerTing-Wei Lan <lantw@src.gnome.org>2019-07-06 00:55:32 +0800
commit46a33a077d1519dcab558841b076e6fbac6e84d9 (patch)
tree751ce0b19f257e77737ac7b696301eb4b4e890eb /gvdb/meson.build
parent5c7b219d5bf66a6dc14c23caa4a2539904f4d0de (diff)
downloaddconf-46a33a077d1519dcab558841b076e6fbac6e84d9.tar.gz
build: Define GVDB_USE_WEAK_SYMBOLS to use weak bindings in gvdb
Fix linking with LLD by using weak symbols in gvdb, and update dconf code to make it compatible with gvdb upstream changes. Fixes https://gitlab.gnome.org/GNOME/dconf/issues/47
Diffstat (limited to 'gvdb/meson.build')
-rw-r--r--gvdb/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/gvdb/meson.build b/gvdb/meson.build
index 1a1aba8..6b98825 100644
--- a/gvdb/meson.build
+++ b/gvdb/meson.build
@@ -10,6 +10,7 @@ gvdb_deps = [
cflags = [
'-DG_LOG_DOMAIN="gvdb (via dconf)"',
'-DG_LOG_USE_STRUCTURED=1',
+ '-DGVDB_USE_WEAK_SYMBOLS',
]
libgvdb = static_library(