summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTomasz Miąsko <tomasz.miasko@gmail.com>2018-12-11 00:00:00 +0000
committerTomasz Miąsko <tomasz.miasko@gmail.com>2019-01-29 15:48:49 +0100
commitd36936fe111147db6ca2cd890ecec48a74ae343a (patch)
tree543c1230190fd51677703a4fd3cb263bfee8dce1 /meson.build
parentc71b3281c5b9c190dbe66b864426baddda8ca7f8 (diff)
downloaddconf-d36936fe111147db6ca2cd890ecec48a74ae343a.tar.gz
bin: Rewrite dconf utility in C
Intentional functional changes: * Update is no longer conditional on mtime. * Help information is shown on erroneous usage, but not otherwise. Fixes issue #38.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4ebdbb3..85bcc02 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project(
- 'dconf', ['c', 'vala'],
+ 'dconf', ['c'],
version: '0.31.2',
license: 'LGPL2.1+',
meson_version: '>= 0.46.0',
@@ -20,7 +20,6 @@ revision = 0
libversion = '@0@.@1@.@2@'.format(soversion, current, revision)
cc = meson.get_compiler('c')
-valac = meson.get_compiler('vala')
# compiler flags
common_flags = ['-DSYSCONFDIR="@0@"'.format(dconf_sysconfdir)]