summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-12 11:48:07 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2018-08-11 22:55:53 +0200
commit082a10cbadd6d7951d12c9b92aa5e1e7278f0068 (patch)
tree3757cee7c80b93ca4908d9277404dd234c0cd286 /meson.build
parente5f8af841b7236507add31d7cb78531f62e35849 (diff)
downloaddconf-082a10cbadd6d7951d12c9b92aa5e1e7278f0068.tar.gz
build: Use get_supported_arguments helper
meson 0.43.0 comes with a new function in the compiler's object called `get_supported_arguments`, which allows checking multiple optiones at once. This patch bumps meson's version number and also takes advantage of this new feature.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 739da14..9ed24ba 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@ project(
'dconf', ['c', 'vala'],
version: '0.28.0',
license: 'LGPL2.1+',
- meson_version: '>= 0.41.0'
+ meson_version: '>= 0.43.0'
)
dconf_version = meson.project_version()
@@ -58,11 +58,7 @@ if get_option('buildtype').contains('debug')
'-Wwrite-strings'
]
- foreach cflag: test_cflags
- if cc.has_argument(cflag)
- common_flags += [cflag]
- endif
- endforeach
+ common_flags += cc.get_supported_arguments(test_cflags)
endif
add_project_arguments(common_flags, language: 'c')