summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <withnall@endlessm.com>2018-08-14 16:00:13 +0100
committerPhilip Withnall <withnall@endlessm.com>2018-08-16 18:58:27 +0100
commitea8c09f14da4b931cdadbabe2be315f6747ac7b7 (patch)
tree2f0b6cad43ed5ce1fd5e0b466126e162011183d4 /meson.build
parented13467de71084e44fc98a9a0e3a2fe99ae6f26c (diff)
downloaddconf-ea8c09f14da4b931cdadbabe2be315f6747ac7b7.tar.gz
build: Enable G_LOG_USE_STRUCTURED=1
This enables structured logging for all parts of dconf, which will make it easier to check for certain log messages in the unit tests. Signed-off-by: Philip Withnall <withnall@endlessm.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ba14507..788cea9 100644
--- a/meson.build
+++ b/meson.build
@@ -35,6 +35,11 @@ endif
add_project_arguments(common_flags, language: 'c')
+dconf_c_args = [
+ '-DG_LOG_DOMAIN="dconf"',
+ '-DG_LOG_USE_STRUCTURED=1',
+]
+
gio_req_version = '>= 2.25.7'
gio_dep = dependency('gio-2.0', version: gio_req_version)