summaryrefslogtreecommitdiff
path: root/service/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-12 11:30:48 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2018-08-11 22:55:53 +0200
commitaf3f39dae005c8c3ceb0a88c38b1c2172b20f1d7 (patch)
tree16f292e77a71bbbac72412f7bbdecad3521e1c15 /service/meson.build
parent5a75f4d0d178e3035a69e2628dc575e9bc80cf98 (diff)
downloaddconf-af3f39dae005c8c3ceb0a88c38b1c2172b20f1d7.tar.gz
build: Rename build options
Following the new meson porting guidelines, this patch renames the build options. The list of changes is as follows: - Remove the enable prefix from boolean options. - Remove the with prefix from string options. - The character separator from multi-word options has been changed to underscore.
Diffstat (limited to 'service/meson.build')
-rw-r--r--service/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/service/meson.build b/service/meson.build
index f651e25..800dd87 100644
--- a/service/meson.build
+++ b/service/meson.build
@@ -1,9 +1,9 @@
-dbus_service_dir = get_option('with-dbus-service-dir').strip()
+dbus_service_dir = get_option('dbus_service_dir')
if dbus_service_dir == ''
dbus_service_dir = join_paths(dconf_datadir, 'dbus-1', 'services')
endif
-dbus_system_service_dir = get_option('with-dbus-system-service-dir').strip()
+dbus_system_service_dir = get_option('dbus_system_service_dir')
if dbus_system_service_dir == ''
dbus_system_service_dir = join_paths(dconf_datadir, 'dbus-1', 'system-services')
endif