summaryrefslogtreecommitdiff
path: root/service/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2020-12-04 11:11:04 +0000
committerSimon McVittie <smcv@debian.org>2020-12-04 11:14:11 +0000
commitfc46e157bd708aa24ee366e027aa7edbaa0c8648 (patch)
tree4b68553e3d6a225b0efa027a876f4a3f4f953f67 /service/meson.build
parent490421c6a89f918dbb75ae14efb66a1ce1fe1399 (diff)
downloaddconf-wip/smcv/systemd-unit.tar.gz
service: Add a systemd unit for D-Bus activationwip/smcv/systemd-unit
On systems using systemd --user and dbus-daemon --session --systemd-activation, this means that dconf is correctly placed in its own cgroup, instead of being part of dbus.service's cgroup. This allows it to be controlled by systemctl --user, have resource limits set and so on. On other systems (in particular those where systemd is not used at all), the SystemdService field is ignored and dbus-daemon will continue to start dconf-service as its own child process ("traditional activation"), making this change harmless to apply. Resolves: https://gitlab.gnome.org/GNOME/dconf/-/issues/24 Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'service/meson.build')
-rw-r--r--service/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/service/meson.build b/service/meson.build
index 19fe670..ad635b0 100644
--- a/service/meson.build
+++ b/service/meson.build
@@ -10,6 +10,15 @@ configure_file(
install_dir: dbus_session_service_dir,
)
+systemd_service = 'dconf.service'
+
+configure_file(
+ input: systemd_service + '.in',
+ output: systemd_service,
+ configuration: service_conf,
+ install_dir: systemd_userunitdir,
+)
+
lib_sources = [
'dconf-blame.c',
'dconf-gvdb-utils.c',