summaryrefslogtreecommitdiff
path: root/shm/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-07-12 16:30:51 +0200
committerMichael Catanzaro <mcatanzaro@igalia.com>2017-10-17 16:32:41 -0500
commitf7a71bd57254912547256045b747f9181eef3529 (patch)
treee7278e8dc0fdddc5b2e6acbd74e72c7626c5f497 /shm/meson.build
parent8ff1b86cb8f6c848be82d99dbb593a50713ce6ad (diff)
downloaddconf-f7a71bd57254912547256045b747f9181eef3529.tar.gz
build: Port to meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. https://bugzilla.gnome.org/show_bug.cgi?id=784910
Diffstat (limited to 'shm/meson.build')
-rw-r--r--shm/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/shm/meson.build b/shm/meson.build
new file mode 100644
index 0000000..01ced55
--- /dev/null
+++ b/shm/meson.build
@@ -0,0 +1,22 @@
+name = meson.project_name() + '-shm'
+
+sources = files('dconf-shm.c')
+
+cflags = '-DG_LOG_DOMAIN="@0@"'.format(meson.project_name())
+
+libdconf_shm = static_library(
+ name,
+ sources: sources,
+ include_directories: top_inc,
+ dependencies: glib_dep,
+ c_args: cflags
+)
+
+libdconf_shm_shared = static_library(
+ name + '-shared',
+ sources: sources,
+ include_directories: top_inc,
+ dependencies: glib_dep,
+ c_args: cflags,
+ pic: true
+)