summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2012-07-11 12:40:22 -0400
committerRyan Lortie <desrt@desrt.ca>2012-07-11 12:42:05 -0400
commitebf22c7253795313870e8d5f112d7d79d2db8969 (patch)
treeb025dbcb4122cfd9c129b7566c6ca56bb24cf2b3 /tests/Makefile.am
parent2108640d5a5188873cee73d0c776ab4b4def855d (diff)
downloaddconf-ebf22c7253795313870e8d5f112d7d79d2db8969.tar.gz
tests/: test the libdbus-1 DBus backend
Add a testcase for the libdbus-1 DBus backend. It uses the existing testcase code and undergoes the same tests as the two other backends. There is one exception: we do not test for failure to connect to D-Bus because the D-Bus connections are passed up-front for the libdbus-1 case, as arguments to dconf_dbus_client_new().
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a4be908..09592e0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -68,6 +68,14 @@ gdbus_filter_LDADD = \
$(gio_LIBS)
gdbus_filter_SOURCES = dbus.c
+TEST_PROGS += libdbus-1
+libdbus_1_CFLAGS = $(gio_CFLAGS) -DDBUS_BACKEND=\"/libdbus-1\"
+libdbus_1_LDADD = \
+ ../dbus-1/libdconf-libdbus-1.a \
+ $(glib_LIBS) \
+ $(dbus_LIBS)
+libdbus_1_SOURCES = dbus.c
+
TEST_PROGS += engine
engine_CFLAGS = $(glib_CFLAGS) -DSRCDIR=\"$(abs_srcdir)\"
engine_LDADD = \