summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/common/meson.build b/common/meson.build
index 90245b7..58e0fa8 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -17,14 +17,12 @@ sources = files(
'dconf-paths.c',
)
-cflags = ['-DG_LOG_DOMAIN="dconf"']
-
libdconf_common = static_library(
'dconf-common',
sources: sources,
include_directories: top_inc,
dependencies: glib_dep,
- c_args: cflags,
+ c_args: dconf_c_args,
pic: true,
)
@@ -33,14 +31,12 @@ libdconf_common_dep = declare_dependency(
link_whole: libdconf_common,
)
-cflags += cc.get_supported_arguments('-fvisibility=hidden')
-
libdconf_common_hidden = static_library(
'dconf-common-hidden',
sources: sources,
include_directories: top_inc,
dependencies: glib_dep,
- c_args: cflags,
+ c_args: dconf_c_args + cc.get_supported_arguments('-fvisibility=hidden'),
pic: true,
)