summaryrefslogtreecommitdiff
path: root/gdbus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gdbus/Makefile.am')
-rw-r--r--gdbus/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/gdbus/Makefile.am b/gdbus/Makefile.am
new file mode 100644
index 0000000..cee235c
--- /dev/null
+++ b/gdbus/Makefile.am
@@ -0,0 +1,21 @@
+include $(top_srcdir)/Makefile.gtester
+
+noinst_LIBRARIES = \
+ libdconf-gdbus-thread.a \
+ libdconf-gdbus-thread-shared.a \
+ libdconf-gdbus-filter.a \
+ libdconf-gdbus-filter-shared.a
+
+libdconf_gdbus_thread_a_CFLAGS = $(gio_CFLAGS)
+libdconf_gdbus_thread_a_SOURCES = \
+ dconf-gdbus-thread.c
+
+libdconf_gdbus_thread_shared_a_CFLAGS = $(libdconf_gdbus_thread_a_CFLAGS) -fPIC -DPIC
+libdconf_gdbus_thread_shared_a_SOURCES = $(libdconf_gdbus_thread_a_SOURCES)
+
+libdconf_gdbus_filter_a_CFLAGS = $(gio_CFLAGS)
+libdconf_gdbus_filter_a_SOURCES = \
+ dconf-gdbus-filter.c
+
+libdconf_gdbus_filter_shared_a_CFLAGS = $(libdconf_gdbus_filter_a_CFLAGS) -fPIC -DPIC
+libdconf_gdbus_filter_shared_a_SOURCES = $(libdconf_gdbus_filter_a_SOURCES)