summaryrefslogtreecommitdiff
path: root/gdbus/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gdbus/meson.build')
-rw-r--r--gdbus/meson.build24
1 files changed, 2 insertions, 22 deletions
diff --git a/gdbus/meson.build b/gdbus/meson.build
index 4dda78d..c22a81d 100644
--- a/gdbus/meson.build
+++ b/gdbus/meson.build
@@ -1,19 +1,9 @@
-name = meson.project_name() + '-gdbus-thread'
-
sources = files('dconf-gdbus-thread.c')
cflags = '-DG_LOG_DOMAIN="@0@"'.format(meson.project_name())
libdconf_gdbus_thread = static_library(
- name,
- sources: sources,
- include_directories: top_inc,
- dependencies: gio_unix_dep,
- c_args: cflags
-)
-
-libdconf_gdbus_thread_shared = static_library(
- name + '-shared',
+ meson.project_name() + '-gdbus-thread',
sources: sources,
include_directories: top_inc,
dependencies: gio_unix_dep,
@@ -21,20 +11,10 @@ libdconf_gdbus_thread_shared = static_library(
pic: true
)
-name = meson.project_name() + '-gdbus-filter'
-
sources = files('dconf-gdbus-filter.c')
libdconf_gdbus_filter = static_library(
- name,
- sources: sources,
- include_directories: top_inc,
- dependencies: gio_unix_dep,
- c_args: cflags
-)
-
-libdconf_gdbus_filter_shared = static_library(
- name + '-shared',
+ meson.project_name() + '-gdbus-filter',
sources: sources,
include_directories: top_inc,
dependencies: gio_unix_dep,