summaryrefslogtreecommitdiff
path: root/gdbus/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gdbus/meson.build')
-rw-r--r--gdbus/meson.build26
1 files changed, 18 insertions, 8 deletions
diff --git a/gdbus/meson.build b/gdbus/meson.build
index c22a81d..1aef9fb 100644
--- a/gdbus/meson.build
+++ b/gdbus/meson.build
@@ -1,23 +1,33 @@
-sources = files('dconf-gdbus-thread.c')
+name = meson.project_name() + '-gdbus-thread'
cflags = '-DG_LOG_DOMAIN="@0@"'.format(meson.project_name())
libdconf_gdbus_thread = static_library(
- meson.project_name() + '-gdbus-thread',
- sources: sources,
+ name,
+ sources: name + '.c',
include_directories: top_inc,
- dependencies: gio_unix_dep,
+ dependencies: libdconf_engine_dep,
c_args: cflags,
pic: true
)
-sources = files('dconf-gdbus-filter.c')
+libdconf_gdbus_thread_dep = declare_dependency(
+ dependencies: libdconf_engine_dep,
+ link_with: libdconf_gdbus_thread
+)
+
+name = meson.project_name() + '-gdbus-filter'
libdconf_gdbus_filter = static_library(
- meson.project_name() + '-gdbus-filter',
- sources: sources,
+ name,
+ sources: name + '.c',
include_directories: top_inc,
- dependencies: gio_unix_dep,
+ dependencies: libdconf_engine_dep,
c_args: cflags,
pic: true
)
+
+libdconf_gdbus_filter_dep = declare_dependency(
+ dependencies: libdconf_engine_dep,
+ link_with: libdconf_gdbus_filter
+)