summaryrefslogtreecommitdiff
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index 7faa269..ad3e30a 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -14,12 +14,19 @@ dconf_proxy_LDADD = \
dconf_proxy_SOURCES = \
../gvdb/gvdb-builder.c \
confinement.c \
+ confinement-apparmor.c \
confinement-flatpak.c \
confinement.h \
permissions.c \
permissions.h \
proxy.c
+if ENABLE_APPARMOR
+dconf_proxy_CPPFLAGS = -DHAVE_APPARMOR
+dconf_proxy_CFLAGS += $(apparmor_CFLAGS)
+dconf_proxy_LDADD += $(apparmor_LIBS)
+endif
+
DISTCLEANFILES = ca.desrt.dconf.service
ca.desrt.dconf.Proxy.service: Makefile