summaryrefslogtreecommitdiff
path: root/service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'service/Makefile.am')
-rw-r--r--service/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/service/Makefile.am b/service/Makefile.am
index 96ad94e..fe3afaa 100644
--- a/service/Makefile.am
+++ b/service/Makefile.am
@@ -1,15 +1,17 @@
include $(top_srcdir)/Makefile.gtester
-AM_CFLAGS = $(gio_CFLAGS) -I$(top_srcdir)/gvdb -I$(top_srcdir)/common -I$(top_srcdir)/shm -Wall -Wmissing-prototypes -Wwrite-strings
-
libexec_PROGRAMS = dconf-service
dbusservice_DATA = ca.desrt.dconf.service
-dconf_service_LDADD = $(gio_LIBS) ../common/libdconf-common.a ../shm/libdconf-shm.a
+dconf_service_CFLAGS = $(gio_CFLAGS)
+dconf_service_LDADD = \
+ ../common/libdconf-common.a \
+ ../gvdb/libgvdb.a \
+ ../shm/libdconf-shm.a \
+ $(gio_LIBS)
+
dconf_service_SOURCES = \
- ../gvdb/gvdb-builder.c \
- ../gvdb/gvdb-reader.c \
dconf-interfaces.h \
dconf-interfaces.c \
dconf-rebuilder.h \