summaryrefslogtreecommitdiff
path: root/service/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'service/meson.build')
-rw-r--r--service/meson.build53
1 files changed, 53 insertions, 0 deletions
diff --git a/service/meson.build b/service/meson.build
new file mode 100644
index 0000000..f651e25
--- /dev/null
+++ b/service/meson.build
@@ -0,0 +1,53 @@
+dbus_service_dir = get_option('with-dbus-service-dir').strip()
+if dbus_service_dir == ''
+ dbus_service_dir = join_paths(dconf_datadir, 'dbus-1', 'services')
+endif
+
+dbus_system_service_dir = get_option('with-dbus-system-service-dir').strip()
+if dbus_system_service_dir == ''
+ dbus_system_service_dir = join_paths(dconf_datadir, 'dbus-1', 'system-services')
+endif
+
+service_conf = configuration_data()
+service_conf.set('libexecdir', dconf_libexecdir)
+
+service = dconf_namespace + '.service'
+
+configure_file(
+ input: service + '.in',
+ output: service,
+ install: true,
+ install_dir: dbus_service_dir,
+ configuration: service_conf
+)
+
+sources = [
+ 'dconf-blame.c',
+ 'dconf-gvdb-utils.c',
+ 'dconf-keyfile-writer.c',
+ 'dconf-service.c',
+ 'dconf-shm-writer.c',
+ 'dconf-writer.c',
+ 'main.c'
+]
+
+sources += gnome.gdbus_codegen(
+ 'dconf-generated',
+ dconf_namespace + '.xml',
+ interface_prefix: dconf_namespace + '.',
+ namespace: 'DConfDBus'
+)
+
+executable(
+ 'dconf-service',
+ sources,
+ include_directories: top_inc,
+ dependencies: gio_unix_dep,
+ link_with: [
+ libdconf_common,
+ libdconf_shm,
+ libgvdb
+ ],
+ install: true,
+ install_dir: dconf_libexecdir
+)